Commande réseau : Cisco

Configurer l’heure

Commandes

Explication

sw_20#clock timezone Belgium 1 La commande clock timezone est utilisé en mode global. La commande est suivie du nom de la zone du fuseau horaire dont on doit afficher l’heure. Ensuite le numero de UTC (Coordinated Univrersal Time) se nombre varie de -23 à 23
sw_20(config)#clock summer-time Belgium+1 recurring last Sun Mar 2:00 last Sun Oct 3:00 Cette commande nous permet la configurer l’heure de façon à ce qu’elle change l’heure d’été et d’hiver automatiquement. Connaître par coeur.

 

 

Verification :

  • Show clock

 

Référence

http://www.cisco.com/c/en/us/td/docs/routers/crs/software/crs_r4-2/system_management/command/reference/b_sysman_cr42crs/b_sysman_cr42crs_chapter_0100.html

Configurer NTP

Un server NTP (Network Time Protocol) est est un serveur qui va nous permettre de synchroniser notre appareil Switch ou Routeur avec une horloge sur un réseau connue comme l’horloge maître. Par défaut cette application bien pratique est désactivée. Les serveurs NTP utilisent UDP comme protocole de transport

sw_20(config)#ip host ntp1.belbone.be 195.13.23.5 Cette commande nous permet d’activer le protocole NTP. Il y a 4 différents serveur en cas de panne. Cette commande est très importante notamment pour les logs.
sw_20(config)#ip host ntp2.belbone.be 195.13.1.153
sw_20(config)#ip host ntp3.belbone.be 195.13.23.7
sw_20(config)#ntp server 10.1.0.27

Verification :

  • show ntp status

Références

http://www.cisco.com/c/en/us/td/docs/switches/datacenter/sw/5_x/nx-os/system_management/configuration/guide/sm_nx_os_cg/sm_3ntp.html#wp1043201
25/05/2015

http://www.cisco.com/cisco/web/support/CA/fr/109/1096/1096158_tdcmecue.html#t3
25/05/2015

 

Configurer port mode Trunk

Un port dit « Trunk” en anglais est un port qui est utilisé par plusieurs VLAN est donc qui peut gérer le trafic pour plusieurs VLANS simultanément. (Utilisé généralement entre switch)

sw_20(config)#interface f0/4 Choix de l’interface 4 (FastEthernet) du switch
sw_20(config-if)#description NOM On ajoute une description aux à l’interface du port 4
sw_20(config-if)#switchport mode trunk Le mode « Trunk » comme expliqué au dessus
sw_20(config-if)#switchport trunk encapsulation dot1q « encapsulation dot1q » précise la façon dont les données vont être mis en paquet. Ici, « dot1q » c’est-à-dire : protocole standard IEEE 802.1q.

C’est le protocole qui passe dans le câble.

sw_20(config-if)#switchport trunk allowed vlan (add) N° Cette commande nous permet de précisez les différents VLANS que l’on permet d’utiliser cette interface.

Dans la cas de dot1q (protocole standard IEEE 802.1q), un tag est inséré entre le champ d’adresse MAC source et le champ Type/Longueur de la trame:

Comme le montre le schéma, le tag dot1q comporte plusieurs informations:

  1. Un identifiant du protocol (2 bytes)
  2. 3 bits pour indiquer une priorité (utilisé pour des fonctionnalités de QoS au niveau de la trame).
  3. CFI: 1 bit servant à garantir la compatibilité entre les trames ethernet et token-ring (ce bit est toujours                à 0 pour une trame ethernet).
  4. L’identifiant du vlan, codé sur 12 bits (valeurs allant de 0 à 4096, certaines d’étant pas utilisées)

Vérifications :

  1. SHOW INTERFACE
  2. SHOW INTERFACE SWITCHPORT
  3. SHOW INTERFACE BRIEF

 

Références

https://www.ciscomadesimple.be/2014/03/20/trunk-dot1q-et-vlan-natif/

http://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus5000/sw/configuration/guide/cli/CLIConfigurationGuide/AccessTrunk.pdf

 

Configurer port mode Access

Le mode « Access » est le mode qui permet la circulation que d’un seul VLAN et donc gère seulement un seul VLAN, contrairement au mode « Trunk ».

sw_20(config)#interface f0/4 Choix de l’interface 4 (FastEthernet) du switch
sw_20(config-if)#description NOM On ajoute une description aux à l’interface du port 4
sw_20(config-if)#switchport mode access On configure l’interface en mode « Access »
sw_20(config-if)#switchport access vlan (add) N° Cette commande nous permet de précisez le VLAN que l’on permet d’utiliser cette interface.

 

 

Vérifications :

  • SHOW INTERFACE
  • SHOW INTERFACE SWITCHPORT
  • SHOW INTERFACE BRIEF

 

Référence

 

http://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus5000/sw/configuration/guide/cli/CLIConfigurationGuide/AccessTrunk.pdf

 

Configurer VTP

Le protocole VTP (VLAN Truck Protocol) réduit la gestion dans un réseau commuté. Quand vous configurez un nouveau VLAN sur un serveur VTP, le VLAN est distribué par tous les commutateurs dans le domaine. Ceci réduit la nécessité de configurer le même VLAN partout. VTP est un protocole propriétaire de Cisco.

 

sw_20(config)#vtp ver N° Cette commande la version du protocole VTP
sw_20(config)#vtp domain NOM Permet de créer un domain sur pour pouvoir communiquer avec un autre appareil
sw_20(config)#vtp password MOTDEPASSE Permet de sécuriser la communication et empêcher un autre switch de prendre la configuration
sw_20(config)#vtp mode CLIENT/SERVER Permet de choisir le mode sur lequel on sera : Client ou Server

 

 

Vérifications :

  • SHOW vtp status
  • show VTP statistics
  • show Vtp counters

 

Références

http://www.cisco.com/cisco/web/support/CA/fr/109/1092/1092443_21.html

http://www.cisco.com/c/en/us/support/docs/lan-switching/vtp/98154-conf-vlan.html

 

Configurer STP

Le protocole STP (Spanning Tree Protocol) est un protocole de couche 2 qui fonctionne sur des ponts et des commutateurs. La spécification du protocole STP est IEEE 802.1D. L’objectif principal du protocole STP est de vérifier que vous ne créez pas de boucles lorsque vous avez des chemins redondants dans votre réseau. Les boucles sont fatales pour un réseau

sw_20(config)#spanning-tree mode pvst Le mode PVST (Per Vlans Spanning-Tree) précise qu’il y a une instance STP par VLAN. Ce qui signifie que chaque VLAN a sa propre topologie sans boucle. Il doit donc utiliser une adresse MAC par VLAN
sw_20(config)#spanning-tree extend system-id Permet au support de gérer 1024 MAC adresses
sw_20(config)#spanning-tree etherchannel guard misconfig Permet d’afficher un message d’erreur quand une boucle est détecter. Cette commande détecter deux types d’erreurs : misconfiguration and misconnection errors.
sw_20(config)#interface range f0/3-4 Choix du range d’interface allant de 3 à 4 (FastEthernet) du switch
sw_20(config-range-if)#switchport mode trunk Voir « Configurer port mode Trunk »
sw_20(config-range-if)#channel-protocol lacp Le protocole LACP* (Link Aggregation Control Protocol) permet de regrouper plusieurs liens physique en un seul. C’est le protocole que l’on choisi pour le « channel protocol »
sw_20(config-range-if)#channel-group 1 mode active Cette commande permet de transformé un port physique en un « EtherChannel »EtherChannel vas nous permettre de faire de l’agrégation de liens. C’est-à-dire que nous allons réunir plusieurs câbles ou ports réseau en un seul lien logique notre PortChannelx (où x et le numéro du port), dans le but d’améliorer le débit de notre lien, et d’accroitre la redondance pour améliorer la disponibilité du lien. Sur un équipement on va pouvoir agréger au maximum 8 liens physiques sur un même PortChannel.
sw_20(config-range-if)#no shutdown Cette commande nous permet d’être sûr que les ports ne sont pas fermés

 

LACP :

Le protocole LACP permet la mise en place d’agrégat de liens qui permet de regrouper plusieurs liens physiques en un seul lien logique et ainsi améliorer les performances en termes de bande-passante, de haute disponibilité et de répartition de charge.

LACP : protocole de niveau 2 qui a pour référence IEEE “802.3ad“.

 

Vérifications :

  • show spanning-tree vlan vlan-id
  • show spanning-tree detail
  • show spanning-tree interface
  • show spanning-tree active
  • show spanning-tree summary
  • show interface port-channel
  • show lacp
  • show port-channel summary

 

Références

 

https://www.ciscomadesimple.be/wp-content/uploads/2011/12/CMSBE_F06_STP.pdf

http://www.cisco.com/c/en/us/td/docs/ios/lanswitch/command/reference/lsw_book/lsw_s2.html#wp1110581

EtherChannel sous Cisco avec LACP

Configurer Telnet

La commande telnet vous permet de spécifier quels hôtes peuvent accéder à la console de l’appliance de sécurité avec Telnet.

 

sw_20(config)#username NOM privilege 0 secret 0 MOTDEPASSE Création d’un utilisateur
sw_20(config)#enable secret MOTDEPASSE Cette commande sécurise le mode « enable »
sw_20(config)#line vty 0 15 cette commande donne accès au ligne virtuel du terminal et nous permet de la/les configurer.
sw_20(config-line)#login local Cette commande précise que l’on doit prendre l’utilisateur local.
sw_20(config-line)#transport input telnet Permet aux telnet de rentrer
sw_20(config-line)#transport output telnet Permet aux telnet de sortir

 

 

Vérifications :

  • show line
  • show telnet server
  • show users
  • show hosts

 

Référence

http://www.cisco.com/c/en/us/td/docs/switches/datacenter/nexus1000/sw/4_0/security/configuration/guide/n1000v_security/security_7telnet.html

 

Configurer Access-List

Une ACL est une liste de règles permettant de filtrer ou d’autoriser du trafic sur un réseau en fonction de certains critères (IP source, IP destination, port source, port destination, protocole, …).

Une ACL permet de soit autoriser du trafic (permit) ou de le bloquer (deny).

sw_20(config)#access-list N° permit ADRESSEIP WILDECARD Cette commande va nous permettre de lister les adresses ip, suivie de leur masque de réseau, qui ont la permission d’avoir un accès.
sw_20(config)#access-list N° deny ADRESSEIP WILDECARD Cette commande va nous permettre de lister les adresses ip, suivie de leur masque de réseau, qui n’ont pas la permission d’avoir un accès. En fin de liste il ne faut pas oublier faire « deny any ».
sw_20(config)#int vlan MGMT Cette commande donne accès à l’interface du VLAN qui nous permettre de la configurer
sw_20(config-if)#ip access-group N° IN/OUT Sur cette commande on est dans l’interface du VLAN,

 

Vérifications :

  • show access-lists
  • show ip access-lists
  • show ip interface

 

Références

https://www.ciscomadesimple.be/wp-content/uploads/2011/06/CMSBE_F04_ACL.pdf

http://labreux.fr/tssi/cisco/ACL-Cisco.pdf

http://cisco.goffinet.org/s2/acl_resume#.VWTGGmBk6Qs

http://www.cisco.com/cisco/web/support/CA/fr/109/1094/1094714_confaccesslists.html

 

 

Sécurité

sw_20(config)#Login block-for 10 attempts 3 within 30 Cette commande nous permet de configurer le temps que l’utilisateur a pour entrer se loger « 10 », le nombre de fois qu’il peut réessayer  « 3 » et cela chaque « 30 » seconde.
sw_20(config)#switchport port-security mac-address sticky Cette commande va précise à l’interface du port d’échanger les données juste avec la mac-adresse du premier appareil (une ligne apparait automatiquement dans la configuration de l’interface) qui se connecte sur le port. Ainsi, une fois que l’adresse est connue, on ne peut plus la changer. En mode dynamique, on peut limiter le nombre d’adresse mais si un utilisateur disparaît, un nouveau peut prendre la place.
sw_20(config)#switchport port-security maximum X on peut spécifier un nombre maximum d’adresse: 1 (par défaut) à 132.
sw_20(config)#switchport port-security violation la commande violation permet de spécifier le comportement à avoir en cas de détection de violation:

protect : les trames venant des adresses non autorisées sont droppées et il n’y a aucun message de log signalant la violation.

-restrict : les trames venant des adresses non autorisées sont droppées, un message de log est créé et une trap SNMP est envoyée.

shutdown : si une trame venant d’une adresse non autorisée est détécté, le port est mis en err-disabled, un message de log est créé et une trap SNMP est envoyée. Une intervention manuelle est nécessaire ou errdisable revovery doit être configuré pour automatiquement faire remonter le port après un certain laps de temps.

 

 

Vérifications :

  • show access-lists sl_def_acl
  • show login
  • show login failures
  • Show port-security
  • show run interface

 

Références

http://www.cisco.com/c/en/us/td/docs/ios/sec_user_services/configuration/guide/15_0s/sec_securing_user_services_15_0S_book/sec_login_enhance.html

http://www.nemako.net/dc2/?post/Port-security

 

 

 

Logging

sw_20(config)#ip domain-name jean.luc Définit un nom de domaine par défaut que le logiciel Cisco IOS utilise pour compléter les noms d’hôte incomplets (noms sans nom de domaine en notation décimale pointée). N’incluez pas le point initial qui sépare un nom incomplet du nom du domaine.
sw_20(config)#username NOM privilege 0 secret 0 MOTDEPASSE Création d’un utilisateur
sw_20(config)#logging on Active le service de log
sw_20(config)#logging buffered 51200 warnings Définition de la mémoire tampon et du niveau d’évènement (en octets)
sw_20(config)#logging rate-limit 25 except 4 de nombre maximum de message enregistré par seconde, dans notre cas c’est 25 message par seconde.« except 4 » signifie sauf pour les messages de niveau 4 et les niveaux plus élevé aussi
sw_20(config)#logging console informational Définition du niveau d’alerte pour la console (niveau 06)
sw_20(config)#logging monitor notification Définition du niveau d’alerte du terminal
sw_20(config)#logging facility local6 Définition de la facilité à l’accès
sw_20(config)#logging origin-id hostname Définition de la source de l’évènement. Impose le nom du switch a la source. Pratique parce qu’on peut changer l’IP sans changer de nom et/ou avoir plusieurs switch
sw_20(config)#logging 192.168.199.152 Définition de l’adresse de destination à laquelle on envoi les logs
sw_20(config)#logging trap warnings Définition du niveau d’émergence qui sera logué dans notre cas (niveau 0 ==> 6)
sw_20(config)#logging source-interface vlan mgmt Définition de la source « IP » des messages log à destination du serveur de log.
sw_20(config)#ip cef Protocole a activer pour le bon fonctionnement du système.
sw_20(config)#access-list logging interval 10 limite l’intervalle entre chaque paquet, dans ce cas-si c’est 10
sw_20(config)#ip accounting access-violations Va filtrer l’adresse ip source (quelle adresse source ?)

Va indiqué qui a essaye de violé le port

 

Je ne suis pas sûr

 

 

Vérifications :

  • show ip cef show
  • show facility-alarm
  • show logging

 

 

Références

http://www.cisco.com/c/en/us/td/docs/ios/12_2/switch/configuration/guide/fswtch_c/xcfcef.html#wp1004541

http://www.cisco.com/c/en/us/td/docs/ios/netmgmt/command/reference/nm_book/nm_09.html

 

Protocole AAA

Authentication : Authentification consiste à déterminer si l’utilisateur ou l’équipement est bien celui qu’il prêtant être, cela ce fait grâce à une authentification nom d’utilisateur/ mot de passe, ou grâce à un certificat.

Authorization : Autorisation consiste à déterminer les droits de l’utilisateur sur les différentes ressources.

Accounting/Audit : Compte permet de garder des informations sur l’utilisation des ressources par l’utilisateur.

switch(config)#username admin privilege 0 secret 0 jean.luc Création d’un utilisateur
switch(config)#ip domain-name jean.luc Définit un nom de domaine par défaut que le logiciel Cisco IOS utilise pour compléter les noms d’hôte incomplets (noms sans nom de domaine en notation décimale pointée). N’incluez pas le point initial qui sépare un nom incomplet du nom du domaine.
switch(config)#aaa new-model active AAA
switch(config)#aaa session-id common Précise  que l’ID de tout les service AAA sont identique.
switch(config)#aaa authentication attempts 5 Définition du nombre de fois qu’on peut échouée notre nom d’utilisateur ou mot de passe.
switch(config)#aaa authentication attempts  login ?????
switch(config)#aaa authentication login strat1 local

switch(config)#aaa authentication login strat2 none

Creation de stratégie pour l’authentification

 

Je ne suis pas sûr.

switch(config)#aaa authorization exec strat1 local

switch(config)#aaa authorization exec strat2 none

?????
switch(config)#aaa authentication user”Please enter your login:” Création d’une bannière pendant la connexion.
switch(config)#aaa authentication password”Please enter your password:” Création d’une bannière pendant la connexion.
switch(config)#aaa authentication fail-message %

****************************************

Incorrect login or password

****************************************

%

Message d’erreur à afficher en cas d’erreur.
switch(config)#aaa authentication config-commands Permet l’utilisa
switch(config)#line con0 choix de la line console 0
switch(config-line)#login authentification Permet à AAA l’utilisation du login pour l’authentification.

 

 

Vérifications :

1) show

 

Références

http://www.lolokai.com/blog/2012/04/09/mise-en-place-dune-authentification-aaa-sur-un-materiel-cisco/

http://www.cisco.com/c/en/us/td/docs/ios/12_2/security/command/reference/fsecur_r/srfathen.html#wp1036828

 

 

Protocole SSH (router)

 

2960-RG(config)#crypto key generate rsa general-keys modulus 1024

 

The name for the keys will be: 2960-RG.mondomaine.fr

% The key modulus size is 1024 bits

% Generating 1024 bit RSA keys, keys will be non-exportable…[OK]

 

2960-RG(config)#

*Mar 1 00:42:43.625: %SSH-5-ENABLED: SSH 1.99 has been enabled

Cette commande génère une clé
routeur-cisco(config)#ip ssh version 2 Configuration SSH
routeur-cisco(config)#line vty 0 4 Activation SSH (line)
routeurcisco(config-line)#login local utilisé l’utilisateur local pour la connexion sur la line
routeur-cisco(config-line)#transport input ssh Autorise l’entrée en ssh sur la line
routeur-cisco(config)#ip ssh logging events les évènements associés aux connexions ssh sont enregistrés
routeur-cisco(config)#ip ssh time-out 60 un délai de 60 secondes est ajouté pour les sessions ssh en cas d’inactivité
routeur-cisco(config)#ip ssh authentication-retries 3 3 essaie maximum à raté avant d’être rejeté.
routeur-cisco(config)#crypto key zeroize rsa Suppression de la clé SSH

 

 

Vérifications :

  • show version
  • Show ip version
  • show crypto key mypubkey RSA
  • SHow ip ssh

 

Référence

Cours 6 ème Mr. Lepere 2014-2015

http://routeur.clemanet.com/configuration-ssh.php

 

 

 

 

 

Configurer DHCP

 

Partie switch

 

sw_07(config)#vlan 120 Création vlan 120
sw_07(config-vlan)#description res_elv On ajoute une description
sw_07(config)#vlan 380 Création vlan 380
sw_07(config-vlan)#description res_ecole On ajoute une description « res-ecole »
sw_07(config)#interface f0/1 Choix de l’interface 1 (FastEthernet) du switch
sw_07(config-if)#switchport mode access Configuration du port en mode Access
sw_07(config-if)#switchport access vlan 120 Autorisation à l’interface à utilisé le vlan 120
sw_07(config-if)#description PC-ELV On ajoute une description « PC-ELV »
sw_07(config-if)#no shutdown Cette commande nous permet d’être sûr que le port n’est pas fermé
sw_07(config)#interface f0/21 Choix de l’interface 21 (FastEthernet) du switch
sw_07(config-if)#switchport mode access Configuration du port en mode Access
sw_07(config-if)#switchport access vlan 120 Autorisation à l’interface à utilisé le vlan 120
sw_07(config-if)#description gateway On ajoute une description « gateway »
sw_07(config-if)#no shutdown Cette commande nous permet d’être sûr que le port n’est pas fermé
sw_07(config)#interface f0/22 Choix de l’interface 22 (FastEthernet) du switch
sw_07(config-if)#switchport mode access Configuration du port en mode Access
sw_07(config-if)#switchport access vlan 380 Autorisation à l’interface à utilisé le vlan 380
sw_07(config-if)#description router_Elu On ajoute une description « router_Elu »
sw_07(config-if)#no shutdown Cette commande nous permet d’être sûr que le port n’est pas fermé
sw_07(config)#interface f0/24 Choix de l’interface 22 (FastEthernet) du switch
sw_07(config-if)#switchport mode access Configuration du port en mode Access
sw_07(config-if)#switchport access vlan 380 Autorisation à l’interface à utilisé le vlan 380
sw_07(config-if)#description to380 On ajoute une description « to380 »

 

 

Partie routeur

 

router_07(config)#interface f0/1 Choix de l’interface 0 (FastEthernet) du switch
router_07(config-if)#ip address 10.27.7.1 255.255.255.0 Attribution d’une adresse ip fixe à l’interface
router_07(config-if)#description vlan 299 On ajoute une description plan mgmt
router_07(config-if)#no shutdown Cette commande nous permet d’être sûr que le port n’est pas fermé
router_07(config)#ip dhcp pool jean.luc
router_07(dhcp- config)#network 10.27.7.0 255.255.255.0 défini le réseau et son masque de sous-réseau
router_07(dhcp-config)#domain-name res_elv Définit un nom de domaine par défaut que le logiciel Cisco IOS utilise pour compléter les noms d’hôte incomplets (noms sans nom de domaine en notation décimale pointée). N’incluez pas le point initial qui sépare un nom incomplet du nom du domaine.
router_07(dhcp-config)#dns-server 192.168.240.12 définit l’adresse du DNS
router_07(dhcp-config)#default-route 10.27.7.1 passerelle par défaut
router_07(dhcp-config)#lease 3 le nombre de jour qu’a droit un utilisateurs.
router_07(dhcp-config)#exit retour en mode configuration terminal
router_07(config)#ip dhcp excluded-address 10.27.7.1 10.27.7.10 Réserve une plage d’adresse pour les serveur, imprimantes
router_07(config)#service dhcp Active le service dhcp
router_07(config)#ip route 0.0.0.0 0.0.0.0 fastethernet 0/1 192.168.240.1 ip route pour l’interface fasethernet 0/1
router_07(config)#interface f0/1 Choix de l’interface 0 (FastEthernet) du switch
router_07(config-if)#ip add 192.168.240.207 255.255.254.0 Attribution d’une adresse IP fixe
router_07(config-if)#description vlan 380 On ajoute une description « vlan 380 »
router_07(config-if)#no shutdown Cette commande nous permet d’être sûr que le port n’est pas fermé

 

 

verifications

  • show ip dhcp binding
  • show ip dhcp server statistics
  • show run interface f0/0
  • show service
  • show ip dhcp pool [name]
  • show ip dhcp binding [address]
  • show ip dhcp conflict [address]
  • show ip dhcp database [url]
  • show ip dhcp server statistics [type-number]

 

References

http://routeur.clemanet.com/cisco-dhcp.php

http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipaddr_dhcp/configuration/12-4t/dhcp-12-4t-book/config-dhcp-server.html

http://romain.therrat.fr/cisco-configuration-de-dhcp-via-la-ligne-de-commande-ios/

http://www.it-connect.fr/configurer-le-service-dhcp-sur-un-routeur-cisco/

 

Service à activé

 

router_07(config-if)#service nagle ???????????????????
router_07(config-if)#service password encryption crypte les mot de passe en MD5
router_07(config-if)#service sequence number Permet de logger plus rapidement
router_07(config-if)#service line number The service linenumber command notifies the user of the router’s or switch’s async line number used at login. This can come in handy if you’re having problems with your VTY line — it reminds you what line you’re on. It even works on the console
router_07(config-if)#service timestamp log datetime msec
router_07(config-if)#service timestamp debug datetime msec
router_07(config-if)#service tcp keepalif in Affiche, pour les connexions tcp, si le paquet est bien reçu
router_07(config-if)#service tcp keepalif out Affiche, pour les connexions tcp, si le paquet est bien envoyé

 

 

 

VRF

 

Plan dadressage à configurer pour le SIPS 4 et 5.

Etape 1 : PPP

Router(config)#interface Serial0/0 Choix de l’interface Serial 0/0
Router(config-if)#encapsulation ppp Mode de paquetage
Router(config-if)#ip address 192.168.130.1 255.255.255.252 Adresse réseau de l’interface
Router(config-if)#ppp chap hostname usrgrp01 login utilisé pour l’authenficition
Router(config-if)#ppp chap password 0 jean.luc password pour l’authentification

 

 

Etape 2 : Déclarer une « vc-class »

Une vc-class est une pré-configuration des paramètre VC que l’on appliquera a une interface ATM ou une sub-interface. on peut aussi créer une vc-classe que l’on appliquera a plusieurs interfaces

router(config)#vc-class atm USER Création d’une vc-class atm nommé USER
router(config-if-atm-vc)#ubr+ 10000 512 UBR (Unspecified Bit Rate), précise la bande passante et la priorité (pas obligé)
router(config -if-atm-vc)#inarp 30 Rafraichir la table ARP chaque 30 seconde.
router(config -if-atm-vc)#encapsulation aal5snap protocole avec lesquelles seront emballés pour circulé à travers l’ATM

 

 

Etape 3 : Déclarer une « VRF »

router(config)#ip vrf lan création d’une vrf
router(config-vrf)#description router for lan On ajoute une description « router for lan »
router(config-vrf)#rd 172.16.1.2 :380 !rd = route-distinguisher

 

 

Router(config)#interface ATM 1/0 Choix de l’interface 1/0 ATM du routeur
Router(config-if)#description connected to switch ATM On ajoute une description « connected to switch ATM »
Router(config-if)#no ip address Pas d’adresse IP
Router(config-if)#no ip redirects Elle indique que le routeur ne doit ni générer, ni accepter de paquets ICMP Redirect.
Router(config-if)#no ip unreachables Empeche ICMP à avoir accès au message inaccessible
Router(config-if)#no ip proxy-arp N’autorise pas que d’autre machine fasse une recherche eux-même pour faire une table ARP (sécurité)
Router(config-if)#ip route-cache flow ???????????
Router(config-if)#load-interval 30 ???????????
Router(config-if)#atm sonet stm-1 ???????????
Router(config-if)#no atm ilmi-keepalive ???????????
Router(config)#interface ATM1/0.199 point-to-point Choix de l’interface virtuel ATM1/0.199 du routeur
Router(config-if)#description atm logique mgmt Ajout d’une description
Router(config-if)#ip address 192.168.120.38 255.255.255.252 Attribution d’une adresse IP statique.
Router(config-if)#no ip redirects Elle indique que le routeur ne doit ni générer, ni accepter de paquets ICMP Redirect.
Router(config-if)#no ip unreachables Empeche ICMP à avoir accès au message inaccessible
Router(config-if)#no ip proxy-arp N’autorise pas que d’autre machine fasse une recherche eux-même pour faire une table ARP (sécurité)
Router(config-if)#ip accounting access-violations ???????????
Router(config-if)#pvc 0/199 Attribution de la route à utiliser.
Router(config-if-pvc)#class-vc user Attribution de la configuration pour cette route.

Etape 4 : Configurer l’ATM (interface physique)

 

 

Etape 5 : Configurer l’ATM (interface logique)

Router(config)#interface ATM 1/0.32 point-to-point Choix de l’interface
Router(config-if)#description connected to LAN Network Ajout dune description
Router(config-if)#backup delay 30 60 Je passe la main après 30 seconde de shut et reprend si je suis en fonction après 60 seconde
Router(config-if)#backup interface serial 0/0 Choix de l’interface de backup. Ne pas oublier de l’activer.
Router(config-if)#ip vrf forwarding lan Précise que l’interface fait partie du routeur virtuel.
Router(config-if)#ip address 192.168.230.38 255.255.255.252 Attribution d’une adresse IP statique.
Router(config-if)#no ip redirects Elle indique que le routeur ne doit ni générer, ni accepter de paquets ICMP Redirect.
Router(config-if)#no ip unreachables Empeche ICMP à avoir accès au message inaccessible
Router(config-if)#no ip proxy-arp N’autorise pas que d’autre machine fasse une recherche eux-même pour faire une table ARP (sécurité)
Router(config-if)#ip accounting access-violations ??????????????
Router(config-if)#ip virtual-reassembly Cette commande envoie les paquets a partir de ce point dans l’ordre et donc mais de gestion à faire plus de ressources libre plus rapidement.
Router(config-if)#pvc 0/32 Choisi la route à utilisé
Router(config-if)#class-vc user Application d’une configuration pour une l’ATM.
router(config)#interface f0/0
router(config-if)#description interface f0/21
router(config-if)#ip address 10.27.9.1 255.255.255.0 Attribution d’une adresse IP statique.
 router(config-if)#ip vrf forwarding lan Précise que l’interface fait partie du routeur virtuel.

 

 

Etape 6 : Ligne de secours (routeur virtuel)

router(config)#interface Serial0/0
router(config-if)#description ligne backup Ajout d’une description.
router(config-if)#ip vrf forwarding lan Précise que l’interface fait partie du routeur virtuel.
router(config-if)#ip adresse 192.168.230.38 Attribution d’une adresse IP statique.
router(config-if)#encapsulation ppp ??????????????
router(config-if)#ppp chap hostname usrgrp07 ??????????????
router(config-if)#ppp chap password 0 group07 ??????????????

 

 

Etape 7 : IP route

 

Router(config)#ip forward-protocol nd Précise qu’elle protocole utilisé en cas de « forwarding broadcast packets »
Router(config)#ip route 0.0.0.0 0.0.0.0 192.168.120.37 spécifie la passerelle par défaut
Router(config)#ip route vrf LAN 0.0.0.0 0.0.0.0 192.168.230.37 Passerelle par défaut pour la VRF LAN
Router(config)#ip route vrf LAN 0.0.0.0 0.0.0.0 192.168.130.37 5 Passerelle par défaut pour la ligne de backup le chiffre mis toute à la fin « 5 » est un nombre de priorité, plus petit elle est plus elle sera prioritaire.

 

 

Etape 8 : Interface Loopback (à completer)

 

Router(config)#interface loopback 0 Création d’une interface loopback pour le router physique.
Router(config-if)#ip address 192.168.242.254 255.255.255.255 Attribution de l’adresse IP
Router(config-if)#description interface de loopback physique description de l’interace.
Router(config)#interface loopback 1 Création d’une interface loopback pour le router virtuel
Router(config-if)#description interface de loopback virtuel description de l’interace.
Router(config-if)#ip vrf forwarding lan Précise que l’interface fait partie du routeur virtuel.
Router(config-if)#ip address 10.27.9.254 255.255.255.255 Attribution d’une adresse IP statique.
Router(config)#ping ip vrf lan X.X.X.X permet de pinger l’interface

 

 

Vérifications :

  • show ip protocole vrf user
  • show ip route vrf user
  • show ip vrf brief
  • show ip vrf detail
  • show ip vrf user
  • ping

 

Références

https://www.ciscomadesimple.be/2010/10/25/configuration-dune-interface-loopback/

http://www.simonweb.be/reseaux-commandes-routeurs-cisco/21-configuration-chap-sur-ppp-sur-deux-routeurs-cisco.html

http://processnet-info.fr/reseau/vrfs-et-routage-ospf/

https://www.ciscomadesimple.be/wp-content/uploads/2014/01/Live01-Intro-VRF.pdf

http://www.cisco.com/c/en/us/td/docs/ios/12_2/wan/configuration/guide/fwan_c/wcfatm.html

http://processnet-info.fr/reseau/vrfs-et-routage-ospf/

http://www.simonweb.be/reseaux-commandes-routeurs-cisco/21-configuration-chap-sur-ppp-sur-deux-routeurs-cisco.html

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4500/12-2/31sg/configuration/guide/conf/vrf.pdf

http://www.nemako.net/dc2/index.php?category/Cisco

http://www.cisco.com/c/en/us/td/docs/net_mgmt/active_network_abstraction/3-7/reference/guide/ANARefGuide37/vrf.html

http://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst4500/12-2/15-02SG/configuration/guide/config/vrf.html

https://www.cisco.com/web/FR/documents/pdfs/newsletter/ciscomag/2010/01/ciscomag_30__virtualization-segmentation.pdf

http://www.cisco.com/c/en/us/td/docs/ios-xml/ios/atm/configuration/xe-2/atm-xe-2-book/atm-cfg-atm-xe.html

Advertisements
Standard